Starcraft 2 crashes...

Started by piranha, March 09, 2010, 05:41:48 PM

Previous topic - Next topic


Hi, starcraft 2 crashes when i run it. After the loading screen it crashes and this is what i get.

Problem signature:
Problem Event Name: APPCRASH
Application Name: SC2.exe
Application Version:
Application Timestamp: 4b722f92
Fault Module Name: SC2.exe
Fault Module Version:
Fault Module Timestamp: 4b722f92
Exception Code: c0000005
Exception Offset: 004ac336
OS Version: 6.0.6001.
Locale ID: 1033
Additional Information 1: 13d0
Additional Information 2: 67f0575b6041c07d04891ecf5f2fc62e
Additional Information 3: 7396
Additional Information 4: e1ccb5d6565148e192d5f9ae7c042e43

Anyone have any idea what the problem could be? I'm running windows vista. My computer specs are:

Processor Name: Quad-Core Intel Xeon
Processor Speed: 2.8 GHz
Number Of Processors: 2
Total Number Of Cores: 8
L2 Cache (per processor): 12 MB
Memory: 2 GB
Bus Speed: 1.6 GHz
Chipset Model: ATI Radeon HD 2600


If it's anything like what I had, you could just delete the folder in AppData > Local > Blizzard Entertainment folder. Booting up SC2 will create a new one. If you have anything custom in your Cache folder inside the folder, you'll want to back that up.

If that doesn't solve the problem, I'd do a reinstall.


Just wanted to chime in and say that I had a similar problem when I installed new nvidia drivers for my Alienware M11x.  I would basically start up Starcraft 2, it would get to the loading screen, then flash the main screen and exit to the desktop.

I played around with settings, and tried the "delete appuser fix" that everyone is talking about, but for whatever reason I don't *have* an appuser folder in my user directory.  I did a full system search for all folders named "appuser" "blizzard entertainment" or even "" and it came up with nothing.

I did however fix the problem.  I have an antivirus suite (Comodo Internet Security) that uses a behavior monitor.  Once I turned off behavior monitoring, Starcraft 2 started like a champ.  When I turned it back on, it went back to crashing to the desktop.  I'm guessing I have to go in and make a rule for Starcraft in my antivirus or something.

Either way, it's something to look into if you're having this problem. 


I imagine he fixed his problem considering that post was from 10 months ago =P